Back to overview
Degraded

Email delivery and processing is delayed.

May 2, 2026 at 1:49pm UTC
Affected services
Atomicwork

Resolved
May 2, 2026 at 6:26pm UTC

The issue has been resolved and performance has returned to normal. Thank you for your patience.

Updated
May 2, 2026 at 5:59pm UTC

Our team is still working to resolve the issue causing slower performance. We will share another update soon. Thank you for your patience.

Updated
May 2, 2026 at 4:35pm UTC

Our team is still working to resolve the issue causing slower performance. We will share another update soon. Thank you for your patience.

Updated
May 2, 2026 at 4:03pm UTC

Our team is still working to resolve the issue causing slower performance. Some users may continue to experience delays. We will share another update soon. Thank you for your patience.

Updated
May 2, 2026 at 3:31pm UTC

Our team is still working to resolve the issue causing slower performance. Some users may continue to experience delays. We will share another update soon. Thank you for your patience.

Updated
May 2, 2026 at 3:00pm UTC

We are continuing to investigate the issue causing degraded performance. Some users may still experience slow response times. We’ll share another update shortly.

Created
May 2, 2026 at 1:49pm UTC

Email delivery and processing is delayed, we are actively working on resolving the issue