Back to overview
atom chat on slack is degraded
May 14, 2026 at 3:00pm UTC
Affected services
Atom (Slack)
Atom (Slack)
Resolved
May 14, 2026 at 3:00pm UTC
atom on slack is not operational
Affected services
Resolved
May 14, 2026 at 3:00pm UTC
atom on slack is not operational
Affected services