Back to overview
Downtime

Atom outage: voice and screen share unavailable

May 28, 2026 at 2:45pm UTC
Affected services
Atom (UAG) - user's voice input
Atom (UAG) - screen sharing

Resolved
May 28, 2026 at 4:30pm UTC

Resolved: Voice calls and screen sharing on Atom are now fully operational following resolution of the upstream provider issue. Thank you for your patience. we will continue to monitor actively.

Updated
May 28, 2026 at 3:45pm UTC

Update: Atom voice and screen share are now intermittently working - degraded performance rather than a full outage. We'll share updates as we have them. Thank you for your patience

Created
May 28, 2026 at 2:45pm UTC

We're currently experiencing degraded performance with voice and screen share features due to an issue with one of our upstream providers. Our team is actively monitoring the situation and working with the provider on a resolution. Other Atom services remain unaffected. We apologize for the inconvenience and will share updates as soon as we have more information.