Back to overview
Resolved

Email delivery degraded

Jul 30, 2026 at 4:00pm UTC
Affected services
Email Processing
Email Processing

Resolved
Jul 30, 2026 at 7:00pm UTC

The issue is now fully resolved and email delivery has returned to normal.

Updated
Jul 30, 2026 at 4:55pm UTC

Outbound email was delayed or failed to send, including notifications, approval requests, and agent replies are affected. Will share an update shortly.

Created
Jul 30, 2026 at 4:00pm UTC

Issue in email delivery. We are actively investigating it.